GeometryPushModelTransform(Vector3d) Method

Pushes a model transformation vector for the current transformation stack. The specified transformation is concatenated to the current model transformation (which is initially the identity transform). The resulting model transformation is subsequently applied to all geometry introduced into this vectorization context, until popModelTransform() is called.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract bool PushModelTransform(
        Vector3d normal
)

Parameters

normal  Vector3d
[in] Transformation vector.

Return Value

Boolean
true. This method also throws a corresponding exception if it fails.
See Also

©  Bricsys NV. All rights reserved.