TransactionManagerGetObject(ObjectId, OpenMode, Boolean) Method

Calls the OpenObject() method of the underlying C++ object for the passed id within the specified open mode.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual DBObject GetObject(
        ObjectId id,
        OpenMode mode,
        bool openErased
)

Parameters

id  ObjectId
[in] Identifier of the object to obtain access to.
mode  OpenMode
[in] Mode to obtain in.
openErased  Boolean
[in] Flag that specifies whether to obtain an object if it was erased.

Return Value

DBObject
A handle to the retrieved object.
Remarks
It is recommended to check whether the retrieved object is valid after method execution.
See Also

©  Bricsys NV. All rights reserved.