TransactionManager Class

This .NET class wraps the OdDbTransactionManager class. This class is used to manage transactions and provides additional functionality to manage the transaction-resident objects.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesTransactionManager
          Bricscad.ApplicationServicesTransactionManager

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class TransactionManager : RXObject

The TransactionManager type exposes the following members.

Constructors
  Name Description
Protected method TransactionManager Initializes a new instance of the TransactionManager class
Top
Properties
  Name Description
Public property NumberOfActiveTransactions Property that represents the number of active transactions in the transaction manager.
Public property TopTransaction Property that represents the top transaction of the transaction manager.
Top
Methods
  Name Description
Public method AddNewlyCreatedDBObject Adds or removes a newly created database record object to the top transaction.
Protected method CreateTransaction  
Public method GetAllObjects Searches all currently existing transaction objects and retrieves a handle to the collision of these objects.
Public method GetObject(ObjectId, OpenMode) Calls the OpenObject() method of the underlying C++ object for the passed id within the specified open mode.
Public method GetObject(ObjectId, OpenMode, Boolean) Calls the OpenObject() method of the underlying C++ object for the passed id within the specified open mode.
Public method GetObject(ObjectId, OpenMode, Boolean, Boolean) Calls the OpenObject() method of the underlying C++ object for the passed id within the specified open mode.
Public method QueueForGraphicsFlush Prepares a queue of the graphics modifications for all transaction-resident modified entities for any transactions of this transaction manager object. Currently not implemented.
Public method StartOpenCloseTransaction Creates and returns a just-created, properly initialized OpenCloseTransaction object.
Public method StartTransaction Starts a new transaction.
Top
See Also

©  Bricsys NV. All rights reserved.