TorusSet(Double, Double, Point3d, Vector3d) Method

Sets the parameters for this torus according to the arguments.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void Set(
        double majorRadius,
        double minorRadius,
        Point3d origin,
        Vector3d axisOfSymmetry
)

Parameters

majorRadius  Double
[in] The major *radius* of this torus. The major radius is the distance from the origin to the center of the circular arc.
minorRadius  Double
[in] The minor *radius* of this torus. The minor radius defines the radius of the circular arc.
origin  Point3d
[in] The origin of this torus.
axisOfSymmetry  Vector3d
[in] Axis of symmetry (rotation).
See Also

©  Bricsys NV. All rights reserved.