Torus Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometryTorus

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Torus : Surface

The Torus type exposes the following members.

Constructors
  Name Description
Public method Torus Default constructor for the Torus class. Creates a default corresponding C++ object (torus) with the following properties: * Minor radius = 0.5. * Start angle for the U parameter = -OdaPI. * End angle for the U parameter = OdaPI. * Start angle for the V parameter = -OdaPI. * End angle for the V parameter = OdaPI.
Public method Torus(Double, Double, Point3d, Vector3d) Constructor for the Torus class.
Public method Torus(Double, Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) Constructor for the Torus class.
Top
Properties
  Name Description
Public property AxisOfSymmetry  
Public property Center  
Public property IsApple  
Public property IsDegenerate  
Public property IsDoughnut  
Public property IsHollow  
Public property IsLemon  
Public property IsOuterNormal  
Public property IsVortex  
Public property MajorRadius  
Public property MinorRadius  
Public property ReferenceAxis  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetAnglesInU Retrieves the start and end angles about the axis of symmetry.
Public method GetAnglesInV Retrieves the start and end angles about the tube.
Public method IntersectWith(LinearEntity3d) Calculates intersection points with the specified linear entity.
Public method IntersectWith(LinearEntity3d, Tolerance) Calculates intersection points with the specified linear entity according to a tolerance.
Public method Set(Double, Double, Point3d, Vector3d) Sets the parameters for this torus according to the arguments.
Public method Set(Double, Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) Sets the parameters for this torus according to the arguments.
Public method SetAnglesInU Sets the start and end angles about the axis of symmetry.
Public method SetAnglesInV Sets the start and end angles about the axis of symmetry.
Top
See Also

©  Bricsys NV. All rights reserved.