LineSegment2dGetSegmentLength(Double, Double,
Tolerance) Method
|
Returns the length of the line segment between
the two parameter values according to a tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public double GetSegmentLength(
double fromParameter,
double toParameter,
Tolerance tolerance
)
Public Function GetSegmentLength (
fromParameter As Double,
toParameter As Double,
tolerance As Tolerance
) As Double
public:
double GetSegmentLength(
double fromParameter,
double toParameter,
Tolerance tolerance
)
member GetSegmentLength :
fromParameter : float *
toParameter : float *
tolerance : Tolerance -> float
Parameters
- fromParameter Double
- [in] First parameter value that represents the start of the
line segment.
- toParameter Double
- [in] Second parameter value that represents the end of the line
segment.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Double
See Also