LineSegment2d Class

This class represents line segments in 2D space. For more information, see Working with Lines.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryCurve2d
          Teigha.GeometryLinearEntity2d
            Teigha.GeometryLineSegment2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class LineSegment2d : LinearEntity2d

The LineSegment2d type exposes the following members.

Constructors
  Name Description
Public method LineSegment2d Default constructor for the LineSegment2d class. Creates a default corresponding C++ object with the lower parameter set to 0.0 and the upper parameter set to 1.0.
Public method LineSegment2d(Point2d, Point2d) Constructor for the LineSegment2d class. Creates a line segment with two specified points.
Public method LineSegment2d(Point2d, Vector2d) Constructor for the LineSegment2d class. Creates a line segment with a point and vector.
Top
Properties
  Name Description
Public property EndPoint  
Public property Length  
Public property MidPoint  
Public property StartPoint  
Top
Methods
  Name Description
Public method BaryComb  
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetBisector Returns the infinite perpendicular bisector of this line segment.
Public method GetSegmentLength(Double, Double) Returns the length of the line segment between the two parameter values.
Public method GetSegmentLength(Double, Double, Tolerance) Returns the length of the line segment between the two parameter values according to a tolerance.
Public method Set(Point2d, Point2d) Specifies points for this line segment.
Public method Set(Point2d, Vector2d) Specifies a point and vector for this line segment.
Public method Set(Curve2d, Point2d, Double) Specifies the parameters for this line according to the arguments.
Public method Set(Curve2d, Curve2d, Double, Double) Specifies the parameters for this line according to the arguments.
Top
See Also

©  Bricsys NV. All rights reserved.