NurbCurve2dSetFitData(Point2dCollection,
Vector2d, Vector2d,
KnotParameterizationEnum, Tolerance) Method
|
Sets the fit data for this spline.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetFitData(
Point2dCollection fitPoints,
Vector2d startTangent,
Vector2d endTangent,
KnotParameterizationEnum knotParam,
Tolerance fitTolerance
)
Public Sub SetFitData (
fitPoints As Point2dCollection,
startTangent As Vector2d,
endTangent As Vector2d,
knotParam As KnotParameterizationEnum,
fitTolerance As Tolerance
)
public:
void SetFitData(
Point2dCollection^ fitPoints,
Vector2d startTangent,
Vector2d endTangent,
KnotParameterizationEnum knotParam,
Tolerance fitTolerance
)
member SetFitData :
fitPoints : Point2dCollection *
startTangent : Vector2d *
endTangent : Vector2d *
knotParam : KnotParameterizationEnum *
fitTolerance : Tolerance -> unit
Parameters
- fitPoints Point2dCollection
- [in] Interpolation points.
- startTangent Vector2d
- [in] Start tangent.
- endTangent Vector2d
- [in] End tangent.
- knotParam KnotParameterizationEnum
-
- fitTolerance Tolerance
- [in] Geometric tolerance.
Remarks
Replaces any
existing spline data (fit or NURBS) with the fit data fitPoints,
startTangent, endTangent, knot parameterization, and fitTolerance.
The fitPoints parameter must contain two or more points. If
fitTolerance is not 0, the constructed spline may not pass through
the fit points, but the maximum distance from any fit point to the
constructed spline is no greater than fitTolerance.
See Also