Solid3dProjectOnToSolid
Method
|
Creates non-database resident entities by
projecting the specified entity along the projection direction to
the solid.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Entity[] ProjectOnToSolid(
Entity entityToProject,
Vector3d projectionDirection
)
Public Function ProjectOnToSolid (
entityToProject As Entity,
projectionDirection As Vector3d
) As Entity()
public:
array<Entity^>^ ProjectOnToSolid(
Entity^ entityToProject,
Vector3d projectionDirection
)
member ProjectOnToSolid :
entityToProject : Entity *
projectionDirection : Vector3d -> Entity[]
Parameters
- entityToProject Entity
- [in] Entity to be projected.
- projectionDirection Vector3d
- [in] Vector determining the projection direction.
Return Value
Entity
Remarks
If a Point object
is specified as the entity to be projected, the result of the
projection is a Point object representing the nearest point on the
solid. This method is implemented only for the Spatial
modeler.
See Also