DBObjectSwapReferences Method
|
This method performs object ID reference
translations similar to those done at the end of deep cloning.
References between objects in the workset have their object
identifiers translated to the swapped object identifiers of the
referenced objects. In contrast to cloning, this translation must
occur in both directions. Accordingly, it is possible to pass two
different ID maps in two different calls to this method. Currently
not implemented.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SwapReferences(
IdMapping idMap
)
Public Overridable Sub SwapReferences (
idMap As IdMapping
)
public:
virtual void SwapReferences(
IdMapping^ idMap
)
abstract SwapReferences :
idMap : IdMapping -> unit
override SwapReferences :
idMap : IdMapping -> unit
Parameters
- idMap IdMapping
- [in] ID map.
See Also