Line
|
The LineWeightConverter type exposes the following members.
Name | Description | |
---|---|---|
![]() |
LineWeightConverter | Initializes a new instance of the LineWeightConverter class |
Name | Description | |
---|---|---|
![]() |
CanConvertFrom(Type) | Returns whether this converter can convert an object of the
given type to the type of this converter. (Inherited from TypeConverter) |
![]() |
CanConvertFrom(ITypeDescriptorContext, Type) | Checks whether the provided source type can be converted to
this type. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type)) |
![]() |
CanConvertTo(Type) | Returns whether this converter can convert the object to the
specified type. (Inherited from TypeConverter) |
![]() |
CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the
specified type, using the specified context. (Inherited from TypeConverter) |
![]() |
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter) |
![]() |
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the provided object and returns the converted
object. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object)) |
![]() |
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using
the invariant culture. (Inherited from TypeConverter) |
![]() |
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using
the invariant culture and the specified context. (Inherited from TypeConverter) |
![]() |
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter) |
![]() |
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified
context. (Inherited from TypeConverter) |
![]() |
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified
context and culture information. (Inherited from TypeConverter) |
![]() |
ConvertTo(Object, Type) | Converts the given value object to the specified type, using
the arguments. (Inherited from TypeConverter) |
![]() |
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type)) |
![]() |
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string
representation. (Inherited from TypeConverter) |
![]() |
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string
representation, using the specified context. (Inherited from TypeConverter) |
![]() |
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter) |
![]() |
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the
given context. (Inherited from TypeConverter) |
![]() |
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the
specified context and culture information. (Inherited from TypeConverter) |
![]() |
CreateInstance(IDictionary) | Re-creates an Object given a set of
property values for the object. (Inherited from TypeConverter) |
![]() |
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is
associated with, using the specified context, given a set of
property values for the object. (Inherited from TypeConverter) |
![]() |
Equals | Determines whether the specified object is equal to the current
object. (Inherited from Object) |
![]() |
Finalize | Allows an object to try to free resources and perform other
cleanup operations before it is reclaimed by garbage
collection. (Inherited from Object) |
![]() |
GetConvertFromException | Returns an exception to throw when a conversion cannot be
performed. (Inherited from TypeConverter) |
![]() |
GetConvertToException | Returns an exception to throw when a conversion cannot be
performed. (Inherited from TypeConverter) |
![]() |
GetCreateInstanceSupported | Returns whether changing a value on this object requires a call
to the CreateInstance(IDictionary) method to
create a new value. (Inherited from TypeConverter) |
![]() |
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call
to CreateInstance(IDictionary) to create a
new value, using the specified context. (Inherited from TypeConverter) |
![]() |
GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() |
GetProperties(Object) | Returns a collection of properties for the type of array
specified by the value parameter. (Inherited from TypeConverter) |
![]() |
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array
specified by the value parameter, using the specified
context. (Inherited from TypeConverter) |
![]() |
GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array
specified by the value parameter, using the specified context and
attributes. (Inherited from TypeConverter) |
![]() |
GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter) |
![]() |
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the
specified context. (Inherited from TypeConverter) |
![]() |
GetStandardValues | Returns a collection of standard values from the default
context for the data type this type converter is designed
for. (Inherited from TypeConverter) |
![]() |
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this
type converter is designed for when provided with a format
context. (Inherited from TypeConverter) |
![]() |
GetStandardValuesExclusive | Returns whether the collection of standard values returned from
GetStandardValues is an exclusive
list. (Inherited from TypeConverter) |
![]() |
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from
GetStandardValues is an exclusive list of
possible values, using the specified context. (Inherited from TypeConverter) |
![]() |
GetStandardValuesSupported | Returns whether this object supports a standard set of values
that can be picked from a list. (Inherited from TypeConverter) |
![]() |
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values
that can be picked from a list, using the specified context. (Inherited from TypeConverter) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
IsValid(Object) | Returns whether the given value object is valid for this
type. (Inherited from TypeConverter) |
![]() |
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type
and for the specified context. (Inherited from TypeConverter) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
© Bricsys NV. All rights reserved. |