MaterialColor Class

This class represents material colors.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceMaterialColor

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class MaterialColor : RXObject

The MaterialColor type exposes the following members.

Constructors
  Name Description
Public method MaterialColor Default constructor for the MaterialColor class. Constructs an object with Inherit color method and 1.0 blend factor.
Public method MaterialColor(Method, Double, EntityColor) Constructor for the MaterialColor class. Constructs an object with the specified color, color method and blend factor.
Top
Properties
  Name Description
Public property Color Property that represents the color of this material color object.
Public property Factor  
Public property Method  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides DisposableWrapperEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides DisposableWrapperGetHashCode)
Top
See Also

©  Bricsys NV. All rights reserved.