ViewSetView(Point3d, Point3d,
Vector3d, Double, Double) Method
|
Sets the camera parameters for this Viewport
object.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetView(
Point3d position,
Point3d target,
Vector3d upVector,
double fieldWidth,
double fieldHeight
)
Public Overridable Sub SetView (
position As Point3d,
target As Point3d,
upVector As Vector3d,
fieldWidth As Double,
fieldHeight As Double
)
public:
virtual void SetView(
Point3d position,
Point3d target,
Vector3d upVector,
double fieldWidth,
double fieldHeight
)
abstract SetView :
position : Point3d *
target : Point3d *
upVector : Vector3d *
fieldWidth : float *
fieldHeight : float -> unit
override SetView :
position : Point3d *
target : Point3d *
upVector : Vector3d *
fieldWidth : float *
fieldHeight : float -> unit
Parameters
- position Point3d
- [in] Camera position.
- target Point3d
- [in] Camera target.
- upVector Vector3d
- [in] Camera up vector.
- fieldWidth Double
- [in] Projection plane (field) width.
- fieldHeight Double
- [in] Projection plane (field) height.
Remarks
This method
defines the transformation from WCS coordinates to normalized
device coordinates. All parameters are in WCS coordinates.
See Also