Section(Point3dCollection, Vector3d)
Constructor
|
Constructor for the Section class. Creates an
instance with the specified parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Section(
Point3dCollection pts,
Vector3d verticalDir
)
Public Sub New (
pts As Point3dCollection,
verticalDir As Vector3d
)
public:
Section(
Point3dCollection^ pts,
Vector3d verticalDir
)
new :
pts : Point3dCollection *
verticalDir : Vector3d -> Section
Parameters
- pts Point3dCollection
- [in] A collection of points that define a section. Cannot
contain duplicate points.
- verticalDir Vector3d
- [in] Vertical direction vector, normal vector to the section
line.
See Also