Assoc2dConstraintCallbackCanBeRelaxed Method
|
Allows client code to inhibit erasing a
dimension constraint when it is not satisfied and would be normally
erased during a relax evaluation.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public virtual bool CanBeRelaxed(
ExplicitConstraint constraint
)
Public Overridable Function CanBeRelaxed (
constraint As ExplicitConstraint
) As Boolean
public:
virtual bool CanBeRelaxed(
ExplicitConstraint^ constraint
)
abstract CanBeRelaxed :
constraint : ExplicitConstraint -> bool
override CanBeRelaxed :
constraint : ExplicitConstraint -> bool
Parameters
- constraint ExplicitConstraint
- [in] The dimension constraint to be erased.
Return Value
Boolean
true if the client code allows the
constraint to be converted to the reference or driven constraint;
false if the client code allows the
constraint to be erased.
See Also