Assoc2dConstraintCallback Class

This class implements the callback for the planar constraint group. Client code can register callback(s) derived from this class that are then called when events are triggered within the planar constraint group.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesAssoc2dConstraintCallback

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class Assoc2dConstraintCallback : DisposableWrapper

The Assoc2dConstraintCallback type exposes the following members.

Constructors
  Name Description
Public method Assoc2dConstraintCallback Default constructor for the Assoc2dConstraintCallback class.
Public method Assoc2dConstraintCallback(OdDbAssoc2dConstraintCallback*, Boolean) Initializes a new instance of the Assoc2dConstraintCallback class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method CanBeRelaxed Allows client code to inhibit erasing a dimension constraint when it is not satisfied and would be normally erased during a relax evaluation.
Public method ConstraintDeactivated This method is called when a constraint is deactivated or reactivated.
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Top
See Also

©  Bricsys NV. All rights reserved.