ExplicitConstraint Class

This class implements a node owned by a constraint group. This node is usually connected with a number of other nodes for which connection is not directed between any two nodes.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesConstraintGroupNode
          Teigha.DatabaseServicesGeometricalConstraint
            Teigha.DatabaseServicesExplicitConstraint

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class ExplicitConstraint : GeometricalConstraint

The ExplicitConstraint type exposes the following members.

Properties
  Name Description
Public property DimDependencyId Property that represents object ID of the dimension dependency object referenced from the dimensional constraint node.
Public property MeasuredValue Property that represents the value of the dimensional constraint object measured from units of the constrained geometry.
Top
Methods
  Name Description
Public method get Property that represents an object ID of the dependency object referenced from this constraint node.
Top
See Also

©  Bricsys NV. All rights reserved.