SurfaceSliceByPlane Method
|
Slices the surface with the specified plane
and sets the surface to be the portion on the positive normal side
plane.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual SurfaceSliceResults SliceByPlane(
Plane slicePlane
)
Public Overridable Function SliceByPlane (
slicePlane As Plane
) As SurfaceSliceResults
public:
virtual SurfaceSliceResults SliceByPlane(
Plane^ slicePlane
)
abstract SliceByPlane :
slicePlane : Plane -> SurfaceSliceResults
override SliceByPlane :
slicePlane : Plane -> SurfaceSliceResults
Parameters
- slicePlane Plane
- [in] Reference to the plane object to be used for slicing the
surface.
Return Value
SurfaceSliceResults
SurfaceSliceResults object that includes negative and positive
sides of the surface that is sliced by the plane.
Remarks
This method is
implemented only for the Spatial modeler.
See Also