mech:compdef-get-description


(mech:compdef-get-description  blkRefOrSolid)

Returns the (optional) description string for the blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

Return

description (string) on success, or NIL in case of an error

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 400b19a0>
(setq res (mech:compdef-get-description blkRefOrSolid))
"This is a simple component."

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

returned description string can be empty



©  Bricsys NV. All rights reserved.