mech:compdef-get-filepath


(mech:compdef-get-filepath  blkRefOrSolid)

Returns the path to the dwg file containing the definition of the (external) component referenced by blkRefOrSolid (ename) entity, where it is defined as a root component.

Arguments

blkRefOrSolid (ename) the entity to query

Return

file path (string) on success, or NIL in case of an error

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 400b19a0>
(setq res (mech:compdef-get-filepath blkRefOrSolid))
"E:\\DDCAD_GIT\\BricsCAD\\bricscad\\src\\lisp\\MCAD\\Components\\box_component.dwg"

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

returned file path string can be empty



©  Bricsys NV. All rights reserved.