mech:compdef-get-name


(mech:compdef-get-name  blkRefOrSolid)

Returns the name of the component, referenced by the blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

Return

name (string) on success, or NIL if name is empty (and in case of an error)

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 400b3440>
(setq res (mech:compdef-get-name blkRefOrSolid))
"Pin"

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note




©  Bricsys NV. All rights reserved.