mech:compdef-get-originalblock


(mech:compdef-get-originalblock  blkRefOrSolid)

Returns the original block definition ename for the component, referenced by the blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

Return

the ename of the BlockDefinition the referenced component is derived from;
returns NIL if the referenced component is the original BlockDefinition;
returns NIL in case of an error

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 400b3440>
(setq res (mech:compdef-get-originalblock blkRefOrSolid))
nil

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

see function (mech:compdef-get-isoriginal)



©  Bricsys NV. All rights reserved.