mDwfExportParams Class

This class represents the parameters for DWF export.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.Export_ImportmDwfExportParams

Namespace: Teigha.Export_Import
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public sealed class mDwfExportParams : DisposableWrapper

The mDwfExportParams type exposes the following members.

Constructors
  Name Description
Public method mDwfExportParams Default constructor for the mDwfExportParams class.
Top
Properties
  Name Description
Public property BackgroundColor This property represents the the background color of the output.
Public property ColorMapOptimize This property indicates whether the color map optimization is used.
Public property Database This property represents the database to export.
Public property EmbedAllFonts This property indicates whether to embed all of the fonts encountered in the document to the .dwf file.
Public property ExportInvisibleLayers This property indicates whether to export invisible layers.
Public property ExportInvisibleText This property indicates whether to export invisible text.
Public property FileName This property represents the name of the .dwf file.
Public property ForceInitialViewToExtents This property indicates whether to force the initial view to extents.
Public property Format This property represents the fortmat of dwf file.
Public property InkedArea This property indicates whether the "inked area" option is used.
Public property MaxPointsInPolygon This property represents the maximum number of points in a polygon.
Public property MaxRasterResolution This property represents the maximum raster resolution.
Public property PageData This property represents the page parameters for dwf export.
Public property Palette This property represents the color palette to export.
Public property Password This property represents the password of the .dwf file.
Public property Publisher This property represents the publisher name.
Public property RGBToJpeg This property indicates whether to save JPEG images in the DWF file rather than RGB.
Public property SkipLayerInfo This property indicates whether to skip layer information.
Public property SkipNamedViewsInfo This property indicates whether to skip named views information.
Public property SourceProductName This property represents the source product name.
Public property UseHLR This property indicates whether the software's vector hidden-line removal is used for the corresponding viewports.
Public property Version This property represents the version of dwf file.
Public property WideComments This property represents the wide comments.
Public property Xsize This property represents the horizontal size of the output screen.
Public property Ysize This property represents the vertical size of the output screen.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.