FontDescriptor Structure

This class provides control of the following font characteristics: * Typeface * Character set * Pitch and family * Bold font * Italic font
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GraphicsInterfaceFontDescriptor

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public struct FontDescriptor

The FontDescriptor type exposes the following members.

Constructors
  Name Description
Public method FontDescriptor Constructor for the FontDescriptor structure. Constructs a font descriptor with the specified typeface, character set, pitch and family, and flags that can make a font bold and/or italic.
Top
Properties
  Name Description
Public property Bold  
Public property CharacterSet  
Public property Italic  
Public property PitchAndFamily  
Public property TypeFace  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method ToString Retrieves a string representation of this font descriptor.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Retrieves a string representation of this font descriptor.
Top
Operators
  Name Description
Public operatorStatic member Equality(FontDescriptor, FontDescriptor) Equality operator for the FontDescriptor structure. Checks whether the left instance is equal to the right instance.
Public operatorStatic member Inequality(FontDescriptor, FontDescriptor) Inequality operator for the FontDescriptor structure. Checks whether the left instance is not equal to the right instance.
Top
See Also

©  Bricsys NV. All rights reserved.