Brep Class

This .NET class wraps the OdDbBrep class.
Inheritance Hierarchy
Namespace:  Teigha.BoundaryRepresentation
Assembly:  TD_MgdBrep (in TD_MgdBrep.dll) Version: 0.0.0.0
Syntax
public sealed class Brep : BrepEntity

The Brep type exposes the following members.

Constructors
  Name Description
Public method Brep(Brep)
Copy constructor for the Brep class.
Public method Brep(Entity)
Constructor for the Brep class. Creates a B-Rep object from another entity.
Public method Brep(FullSubentityPath)
Constructor for the Brep class. Creates a B-Rep from the specified path.
Top
Properties
  Name Description
Public property Complexes
Public property Edges
Public property Faces
Public property Shells
Public property Solid
Represents a solid of this B-Rep.
Public property Surf
Represents a surface of this B-Rep.
Public property Vertices
Top
Methods
  Name Description
Public method GetComplexsStartingFrom
Retrieves a collection of complexes.
Public method GetEdgesStartingFrom
Retrieves a collection of edges.
Public method GetFacesStartingFrom
Retrieves a collection of faces.
Public method GetShellsStartingFrom
Retrieves a collection of shells.
Public method GetVerticesStartingFrom
Retrieves a collection of vertices.
Public method HasTransformation
Checks if this B-Rep has a transformation matrix that transforms this B-Rep (non-identity matrix).
Top
See Also

©  Bricsys NV. All rights reserved.