RibbonImageSource Class

Inheritance Hierarchy
SystemObject
  System.Windows.ThreadingDispatcherObject
    System.WindowsDependencyObject
      System.WindowsFreezable
        System.Windows.Media.AnimationAnimatable
          System.Windows.MediaImageSource
            System.Windows.Media.ImagingBitmapSource
              Bricscad.Private.WindowsRibbonImageSource

Namespace: Bricscad.Private.Windows
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
[TypeConverterAttribute(typeof(RibbonImageSourceConverter))]
public class RibbonImageSource : BitmapSource, 
        IDisposable

The RibbonImageSource type exposes the following members.

Constructors
  Name Description
Public method RibbonImageSource Initializes a new instance of the RibbonImageSource class
Public method RibbonImageSource(Uri, Uri) Initializes a new instance of the RibbonImageSource class
Top
Properties
  Name Description
Public property Image  
Public property ImageThemed  
Public property ImageUri  
Public property LargeImage  
Public property LargeImageThemed  
Public property LargeImageUri  
Top
Methods
  Name Description
Protected method CreateInstanceCore
(Overrides FreezableCreateInstanceCore)
Public method Dispose Releases all resources used by the RibbonImageSource
Protected method Dispose(Boolean) Releases the unmanaged resources used by the RibbonImageSource and optionally releases the managed resources
Public method GetThemedImageSource  
Top
Events
  Name Description
Top
Fields
  Name Description
Protected field m_largeImage  
Protected field m_smallImage  
Top
See Also

©  Bricsys NV. All rights reserved.