Plane(Point3d, Vector3d, Vector3d)
Constructor
|
Constructor for the Plane class. Creates a
plane with points that define u- and v-axes and an origin point of
the plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Plane(
Point3d origin,
Vector3d u,
Vector3d v
)
Public Sub New (
origin As Point3d,
u As Vector3d,
v As Vector3d
)
public:
Plane(
Point3d origin,
Vector3d u,
Vector3d v
)
new :
origin : Point3d *
u : Vector3d *
v : Vector3d -> Plane
Parameters
- origin Point3d
-
- u Vector3d
- [in] A point at the end of the u-axis.
- v Vector3d
- [in] A point at the end of the v-axis.
See Also