Plane Constructor

Overload List
  Name Description
Public method Plane Default constructor for the Plane class. Creates a default corresponding C++ XY plane object.
Public method Plane(Plane) Copy constructor for the Plane class. Copies the passed plane.
Public method Plane(Point3d, Vector3d) Constructor for the Plane class. Creates a plane from a normal to the plane and plane origin.
Public method Plane(Point3d, Point3d, Point3d) Constructor for the Plane class. Creates a plane with points that define the u- and v-axes and an origin point of the plane.
Public method Plane(Point3d, Vector3d, Vector3d) Constructor for the Plane class. Creates a plane with points that define u- and v-axes and an origin point of the plane.
Public method Plane(Double, Double, Double, Double) Constructor for the Plane class. Creates a plane with specified coefficients for the plane equation. The plane equation for this plane is as follows:
C#
a * x + b * y + c * z + d = 0
Top
See Also

©  Bricsys NV. All rights reserved.