EntityGetSubentityPathsAtGraphicsMarker(SubentityType,
Int32, Point3d, Matrix3d, Int32,
ObjectId)
Method
|
Note: This API is now obsolete.
Returns all subentity paths by the graphics
system marker for complex entities that have the ability to
associate an integer identifier (GS marker) with each graphic
primitive or with groups of primitives during drawing.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
[ObsoleteAttribute("Use the overload taking IntPtr instead.")]
public virtual FullSubentityPath[] GetSubentityPathsAtGraphicsMarker(
SubentityType type,
int gsMark,
Point3d pickPoint,
Matrix3d viewTransform,
int numInserts,
ObjectId[] entityAndInsertStack
)
<ObsoleteAttribute("Use the overload taking IntPtr instead.")>
Public Overridable Function GetSubentityPathsAtGraphicsMarker (
type As SubentityType,
gsMark As Integer,
pickPoint As Point3d,
viewTransform As Matrix3d,
numInserts As Integer,
entityAndInsertStack As ObjectId()
) As FullSubentityPath()
public:
[ObsoleteAttribute(L"Use the overload taking IntPtr instead.")]
virtual array<FullSubentityPath>^ GetSubentityPathsAtGraphicsMarker(
SubentityType type,
int gsMark,
Point3d pickPoint,
Matrix3d viewTransform,
int numInserts,
array<ObjectId>^ entityAndInsertStack
)
[<ObsoleteAttribute("Use the overload taking IntPtr instead.")>]
abstract GetSubentityPathsAtGraphicsMarker :
type : SubentityType *
gsMark : int *
pickPoint : Point3d *
viewTransform : Matrix3d *
numInserts : int *
entityAndInsertStack : ObjectId[] -> FullSubentityPath[]
[<ObsoleteAttribute("Use the overload taking IntPtr instead.")>]
override GetSubentityPathsAtGraphicsMarker :
type : SubentityType *
gsMark : int *
pickPoint : Point3d *
viewTransform : Matrix3d *
numInserts : int *
entityAndInsertStack : ObjectId[] -> FullSubentityPath[]
Parameters
- type SubentityType
- [in] The subentity type being queried.
- gsMark Int32
- [in] The GS marker of the subentity being queried.
- pickPoint Point3d
- [in] The WCS point being queried.
- viewTransform Matrix3d
- [in] The WCS->DCS transformation matrix.
- numInserts Int32
- [in] Number of object IDs for block references in the passed
entityAndInsertStack parameter. Currently
not used.
- entityAndInsertStack ObjectId
- [in] The array of objectIds of the objects that are the nested
containers of the subentity.
Return Value
FullSubentityPath
See Also