TableSetGridLineWeight(Int32,
Int32, Int16, LineWeight) Method
|
Sets the grid lineweight for the specified
cell and edges in this table entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetGridLineWeight(
int row,
int col,
short edges,
LineWeight value
)
Public Overridable Sub SetGridLineWeight (
row As Integer,
col As Integer,
edges As Short,
value As LineWeight
)
public:
virtual void SetGridLineWeight(
int row,
int col,
short edges,
LineWeight value
)
abstract SetGridLineWeight :
row : int *
col : int *
edges : int16 *
value : LineWeight -> unit
override SetGridLineWeight :
row : int *
col : int *
edges : int16 *
value : LineWeight -> unit
Parameters
- row Int32
- [in] Row index.
- col Int32
-
- edges Int16
- [in] Grid linetype.
- value LineWeight
-
Remarks
The edge parameter
must have one of the following values:
NameValueDescriptionTopMask 1 Top-edge index
of the table cell. RightMask 2 Right-edge index of the table cell.
BottomMask 4 Bottom-edge index of the table cell. LeftMask 8
Left-edge index of the table cell.
See Also