LoftOptionsCheckLoftCurves Method
|
Checks whether cross section curves and path
curves are valid for the lofting operation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public LoftOptionsCheckCurvesOut CheckLoftCurves(
Entity[] crossSectionCurves,
Entity[] guideCurves,
Entity pPathCurve,
bool displayErrorMessages
)
Public Function CheckLoftCurves (
crossSectionCurves As Entity(),
guideCurves As Entity(),
pPathCurve As Entity,
displayErrorMessages As Boolean
) As LoftOptionsCheckCurvesOut
public:
LoftOptionsCheckCurvesOut^ CheckLoftCurves(
array<Entity^>^ crossSectionCurves,
array<Entity^>^ guideCurves,
Entity^ pPathCurve,
bool displayErrorMessages
)
member CheckLoftCurves :
crossSectionCurves : Entity[] *
guideCurves : Entity[] *
pPathCurve : Entity *
displayErrorMessages : bool -> LoftOptionsCheckCurvesOut
Parameters
- crossSectionCurves Entity
- [in] Array of cross-section curves.
- guideCurves Entity
- [in] Array of guide curves.
- pPathCurve Entity
-
- displayErrorMessages Boolean
- [in] Flag that specifies whether to display error messages.
Default value is false.
Return Value
LoftOptionsCheckCurvesOut
Returns the
LoftOptionsCheckCurvesOut
object that encapsulates the following data: * Flag indicating
whether all of the cross-section curves are open. * Flag indicating
whether all of the cross-section curves are closed. * Flag
indicating whether all of the cross-section curves are
planar.
Remarks
The method throws
the eInvalidInput exception if curves are
invalid.
See Also