LineSegment2d(Point2d, Vector2d)
Constructor
|
Constructor for the LineSegment2d class.
Creates a line segment with a point and vector.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public LineSegment2d(
Point2d point1,
Vector2d vector
)
Public Sub New (
point1 As Point2d,
vector As Vector2d
)
public:
LineSegment2d(
Point2d point1,
Vector2d vector
)
new :
point1 : Point2d *
vector : Vector2d -> LineSegment2d
Parameters
- point1 Point2d
- [in] Start point of the line segment.
- vector Vector2d
- [in] Defines the direction of the line and the second point of
the line.
See Also