EllipticalArc3dIntersectWith(PlanarEntity,
Tolerance) Method
|
Calculates intersection points with the
specified plane according to a geometric tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] IntersectWith(
PlanarEntity plane,
Tolerance tolerance
)
Public Function IntersectWith (
plane As PlanarEntity,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ IntersectWith(
PlanarEntity^ plane,
Tolerance tolerance
)
member IntersectWith :
plane : PlanarEntity *
tolerance : Tolerance -> Point3d[]
Parameters
- plane PlanarEntity
- [in] Plane with which to calculate intersections.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point3d
If the method fails or there are no intersection points, this
method returns nullptr. The returned array consists of two
elements. The first element corresponds to the first intersection
point (if it exists), and the second element corresponds to the
second intersection point (if it exists).
See Also