CircularArc2dIntersectWith(CircularArc2d,
Tolerance) Method
|
Retrieves the intersection points between this
circular arc and the passed circular arc according to the specified
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point2d[] IntersectWith(
CircularArc2d arc,
Tolerance tolerance
)
Public Function IntersectWith (
arc As CircularArc2d,
tolerance As Tolerance
) As Point2d()
public:
array<Point2d>^ IntersectWith(
CircularArc2d^ arc,
Tolerance tolerance
)
member IntersectWith :
arc : CircularArc2d *
tolerance : Tolerance -> Point2d[]
Parameters
- arc CircularArc2d
- [in] A 2D arc to intersect with.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point2d
Array of intersection points.
See Also