ObjectIdGraph Class

This class implements generic graph objects.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesGraph
        Teigha.DatabaseServicesObjectIdGraph

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class ObjectIdGraph : Graph

The ObjectIdGraph type exposes the following members.

Properties
  Name Description
Top
Methods
  Name Description
Top
Remarks
A graph consists of a collection of nodes bi-directionally linked by directional edges. An edge connected to a node is represented as a reference to the node at the other end of the edge. References are classified as either incoming or outgoing. Every incoming reference has a corresponding outgoing reference and vice versa. Each GraphNode object can have any number of references associated with it, enabling the implementation of any graph structure.
See Also

©  Bricsys NV. All rights reserved.