Solid3dCreateExtrudedSolid(Entity,
SubentityId, Double, SweepOptions) Method
|
Creates a solid by extruding a face.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void CreateExtrudedSolid(
Entity sweepEntity,
SubentityId faceSubEntityId,
double height,
SweepOptions sweepOptions
)
Public Overridable Sub CreateExtrudedSolid (
sweepEntity As Entity,
faceSubEntityId As SubentityId,
height As Double,
sweepOptions As SweepOptions
)
public:
virtual void CreateExtrudedSolid(
Entity^ sweepEntity,
SubentityId faceSubEntityId,
double height,
SweepOptions^ sweepOptions
)
abstract CreateExtrudedSolid :
sweepEntity : Entity *
faceSubEntityId : SubentityId *
height : float *
sweepOptions : SweepOptions -> unit
override CreateExtrudedSolid :
sweepEntity : Entity *
faceSubEntityId : SubentityId *
height : float *
sweepOptions : SweepOptions -> unit
Parameters
- sweepEntity Entity
- [in] Swept entity.
- faceSubEntityId SubentityId
- [in] Object ID for the face that must be extruded.
- height Double
- [in] Multiplier for the direction vector.
- sweepOptions SweepOptions
- [in] Set of sweeping options.
Remarks
This method is
implemented only for the Spatial modeler.
See Also