Rectangle3d Structure

This class stores points that define a 3D rectangle.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesRectangle3d

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Rectangle3d

The Rectangle3d type exposes the following members.

Constructors
  Name Description
Public method Rectangle3d Constructor for the Rectangle3d class. Creates a 3D rectangle from the defined points.
Top
Properties
  Name Description
Public property LowerLeft Property that represents the lower-left point of the rectangle.
Public property LowerRight Property that represents the lower-right point of the rectangle.
Public property UpperLeft Property that represents the upper-left point of the rectangle.
Public property UpperRight Property that represents the upper-right point of the rectangle.
Top
Methods
  Name Description
Public method ToString Returns an equivalent string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
See Also

©  Bricsys NV. All rights reserved.