HostApplicationServicesrecoverFile Method

Performs a recover operation on the specified file defined in a file buffer.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public Database recoverFile(
        StreamBuf fileBuff,
        AuditInfo auditInfo,
        string password
)

Parameters

fileBuff  StreamBuf
[in] StreamBuf object from which to read the data.
auditInfo  AuditInfo
[in/out] AuditInfo object.
password  String
[in] Password for a file.

Return Value

Database
Returns a handle to the database of the recovered file.
See Also

©  Bricsys NV. All rights reserved.