AuditInfo Class

This class keeps track of common audit information to be used during a database audit operation.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesAuditInfo

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class AuditInfo : DisposableWrapper

The AuditInfo type exposes the following members.

Constructors
  Name Description
Public method AuditInfo Default constructor for the AuditInfo class.
Top
Properties
  Name Description
Public property AuditPass Property that represents the current audit pass.
Public property FixErrors  
Public property NumEntities  
Public property NumErrors  
Public property NumFixes  
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method ErrorsFixed Increments the count of errors reported as fixed to this object.
Public method ErrorsFound Increments the count of errors that should be interpreted as skipped.
Public method IncNumEntities Increments by one the number of errors reported as processed to this AuditInfo object.
Public method PrintError(DBObject, String, String, String) Notification function called to print error information.
Public method PrintError(String, String, String, String) Notification function called to print error information.
Public method PrintNumEntities If the current number of maintained entities is a multiple of 100, prints the specified message (if not null) followed by the current entity count to the log file where audit information is stored.
Public method RequestRegen Enables fixed objects to specify that regeneration is required.
Public method ResetNumEntities Resets the count of currently maintained entities to 0.
Top
See Also

©  Bricsys NV. All rights reserved.