NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, Tolerance) Constructor

Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points according to the specified tolerance and using given derivatives at the start point and endpoint.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public NurbCurve2d(
        Point2dCollection fitPoints,
        Vector2d startTangent,
        Vector2d endTangent,
        bool startTangentDefined,
        bool endTangentDefined,
        Tolerance fitTolerance
)

Parameters

fitPoints  Point2dCollection
[in] Array of 2D points through which to fit the curve.
startTangent  Vector2d
[in] Start tangent vector.
endTangent  Vector2d
[in] End tangent vector.
startTangentDefined  Boolean
[in] Flag indicating whether startTangent should be used.
endTangentDefined  Boolean
[in] Flag indicating whether endTangent should be used.
fitTolerance  Tolerance
[in] Fit tolerance.
Remarks
If startTangentDefined is 0, startTangent is ignored and the constructor computes the start tangent vector. The same is true for endTangentDefined.
See Also

©  Bricsys NV. All rights reserved.