AcadMLeaderClass Class

Inheritance Hierarchy
SystemObject
  BricscadDbAcadMLeaderClass

Namespace: BricscadDb
Assembly: Interop.BricscadDb (in Interop.BricscadDb.dll) Version: 24.0.0.0
Syntax
public class AcadMLeaderClass : IAcadMLeader, 
        AcadMLeader, IAcadObjectEvents_Event

The AcadMLeaderClass type exposes the following members.

Constructors
  Name Description
Public method AcadMLeaderClass Initializes a new instance of the AcadMLeaderClass class
Top
Properties
Methods
  Name Description
Public method add_Modified  
Public method AddLeader  
Public method AddLeaderLine  
Public method AddLeaderLineEx  
Public method ArrayPolar  
Public method ArrayRectangular  
Public method Copy  
Public method Delete  
Public method Erase  
Public method GetBlockAttributeValue  
Public method GetBlockAttributeValue32  
Public method GetBoundingBox  
Public method GetDoglegDirection  
Public method GetExtensionDictionary  
Public method GetLeaderIndex  
Public method GetLeaderLineIndexes  
Public method GetLeaderLineVertices  
Public method GetVertexCount  
Public method GetXData  
Public method Highlight  
Public method IntersectWith  
Public method Mirror  
Public method Mirror3D  
Public method Move  
Public method remove_Modified  
Public method RemoveLeader  
Public method RemoveLeaderLine  
Public method Rotate  
Public method Rotate3D  
Public method ScaleEntity  
Public method SetBlockAttributeValue  
Public method SetBlockAttributeValue32  
Public method SetDoglegDirection  
Public method SetLeaderLineVertices  
Public method SetXData  
Public method TransformBy  
Public method Update  
Top
Events
  Name Description
Public event Modified  
Top
See Also

©  Bricsys NV. All rights reserved.