EntityGetSubentityPathsAtGraphicsMarker(SubentityType,
IntPtr, Point3d, Matrix3d, ObjectId)
Method
|
Returns all subentity paths by the graphic
system marker for complex entities that have the ability to
associate an integer identifier (GS marker) with each graphic
primitive or with groups of primitives during drawing.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual FullSubentityPath[] GetSubentityPathsAtGraphicsMarker(
SubentityType type,
IntPtr gsMark,
Point3d pickPoint,
Matrix3d viewTransform,
ObjectId[] entityAndInsertStack
)
Public Overridable Function GetSubentityPathsAtGraphicsMarker (
type As SubentityType,
gsMark As IntPtr,
pickPoint As Point3d,
viewTransform As Matrix3d,
entityAndInsertStack As ObjectId()
) As FullSubentityPath()
public:
virtual array<FullSubentityPath>^ GetSubentityPathsAtGraphicsMarker(
SubentityType type,
IntPtr gsMark,
Point3d pickPoint,
Matrix3d viewTransform,
array<ObjectId>^ entityAndInsertStack
)
abstract GetSubentityPathsAtGraphicsMarker :
type : SubentityType *
gsMark : IntPtr *
pickPoint : Point3d *
viewTransform : Matrix3d *
entityAndInsertStack : ObjectId[] -> FullSubentityPath[]
override GetSubentityPathsAtGraphicsMarker :
type : SubentityType *
gsMark : IntPtr *
pickPoint : Point3d *
viewTransform : Matrix3d *
entityAndInsertStack : ObjectId[] -> FullSubentityPath[]
Parameters
- type SubentityType
- [in] The subentity type to query.
- gsMark IntPtr
- [in] The GS marker of the subentity being queried.
- pickPoint Point3d
- [in] The WCS point to query.
- viewTransform Matrix3d
- [in] The WCS->DCS transformation matrix.
- entityAndInsertStack ObjectId
- [in] The array of objectIds of the objects that are the nested
containers of the subentity.
Return Value
FullSubentityPath
See Also