SplineModifyPositionAndTangent
Method
|
Modifies the position and tangent of the point
with a specified parameter.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public ErrorStatus ModifyPositionAndTangent(
double param,
Point3d point,
Vector3d deriv
)
Public Function ModifyPositionAndTangent (
param As Double,
point As Point3d,
deriv As Vector3d
) As ErrorStatus
public:
ErrorStatus ModifyPositionAndTangent(
double param,
Point3d point,
Vector3d deriv
)
member ModifyPositionAndTangent :
param : float *
point : Point3d *
deriv : Vector3d -> ErrorStatus
Parameters
- param Double
- [in] Parameter value of the point to modify.
- point Point3d
- [in] New position of the point on the spline.
- deriv Vector3d
- [in] New value of the tangent vector at the point.
Return Value
ErrorStatus
OK code if the method executes
successfully or an appropriate error code otherwise.
See Also