LightAttenuation Class

This class represents light attenuation parameters.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceLightAttenuation

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class LightAttenuation : RXObject

The LightAttenuation type exposes the following members.

Constructors
  Name Description
Public method LightAttenuation Default constructor for the LightAttenuation class. Constructs the object with no light attenuation. Start attenuation limit is 1.0, and end attenuation limit is 10.0. Attenuation limits are not used.
Top
Properties
  Name Description
Public property AttenuationType  
Public property EndLimit  
Public property StartLimit  
Public property UseLimits  
Top
Methods
  Name Description
Public method Equals
(Overrides DisposableWrapperEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides DisposableWrapperGetHashCode)
Public method SetLimits Specifies attenuation limits.
Top
See Also

©  Bricsys NV. All rights reserved.