EntityIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) Method

Intersects this entity with another entity if possible.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void IntersectWith(
        Entity entityPointer,
        Intersect intersectType,
        Point3dCollection points,
        IntPtr thisGraphicSystemMarker,
        IntPtr otherGraphicSystemMarker
)

Parameters

entityPointer  Entity
[in] Other entity to intersect with.
intersectType  Intersect
[in] Intersection type.
points  Point3dCollection
[out] Receives the array of intersection points.
thisGraphicSystemMarker  IntPtr
[in] GS marker of the subentity of this entity that takes part in the intersection operation. Pass the default value of 0 if not applicable.
otherGraphicSystemMarker  IntPtr
[in] GS marker of the subentity of the passed entity that takes part in the intersection operation. Pass the default value of 0 if not applicable.
Remarks
intersectType must be one of the following: Name Value Description OnBothOperands 0 Do not extend bounding box edges for both intersecting entities. This method calculates intersections only where the bounding box lines actually intersect. ExtendThis 1 Extend bounding box edges of this entity, if necessary, when calculating intersections. The bounding box of the second entity (which is passed as an argument) is not extended. ExtendArgument 2 Extend bounding box edges of the other entity (which is passed as an argument),if necessary, when calculating intersections. The bounding box of this entity is not extended. ExtendBoth 3 Extend bounding box edges for both intersecting entities, if necessary.
See Also

©  Bricsys NV. All rights reserved.