LayoutPaperPEDrawMargins
Method
|
This method is called during vectorization to
draw the paper margins.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool DrawMargins(
Layout layout,
WorldDraw worldDraw,
Point3dCollection points
)
Public MustOverride Function DrawMargins (
layout As Layout,
worldDraw As WorldDraw,
points As Point3dCollection
) As Boolean
public:
virtual bool DrawMargins(
Layout^ layout,
WorldDraw^ worldDraw,
Point3dCollection^ points
) abstract
abstract DrawMargins :
layout : Layout *
worldDraw : WorldDraw *
points : Point3dCollection -> bool
Parameters
- layout Layout
- [in] Layout that is being vectorized.
- worldDraw WorldDraw
- [in/out] Draw object that can be used by this function to set
the necessary attributes and create the necessary geometry.
- points Point3dCollection
- [in] Collection of points that contains the four margin
points.
Return Value
Boolean
true if the margins are successfully
drawn, or
false if the layout uses a
default rendering of the margins.
See Also