LayoutPaperPE Class

This class is the Protocol Extension class for OdDbLayout objects. The Protocol Extension class can be registered in the Layout class to provide a vectorization client the opportunity to customize the drawing of the background paper during PaperSpace vectorization.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesLayoutPaperPE

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class LayoutPaperPE : RXObject

The LayoutPaperPE type exposes the following members.

Constructors
  Name Description
Protected method LayoutPaperPE Initializes a new instance of the LayoutPaperPE class
Protected method LayoutPaperPE(IntPtr, Boolean) Initializes a new instance of the LayoutPaperPE class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method DrawBorder This method is called during vectorization to draw the paper border.
Public method DrawMargins This method is called during vectorization to draw the paper margins.
Public method DrawPaper This method is called during vectorization to draw the paper.
Public methodStatic member GetClass Retrieves the class associated with this protocol extension.
Top
See Also

©  Bricsys NV. All rights reserved.