Layout Class |
The Layout type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Layout | Default constructor for the Layout class. |
![]() |
Layout(IntPtr, Boolean) | Initializes a new instance of the Layout class |
Name | Description | |
---|---|---|
![]() |
![]() |
AnnoAllVisible | Property that indicates whether to display all annotative objects, even those that do not support the current annotation scale. |
![]() |
![]() |
![]() |
BlockTableRecordId | Property that represents the object ID of the PaperSpace BlockTableRecord associated with this Layout object. |
![]() |
![]() |
![]() |
![]() |
![]() |
CurrentViewportId | Property that represents the object ID of the viewport that was last active in this Layout object. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Extents | Property that represents extents for this Layout object. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
LayoutName | Property that represents the name of this Layout object. |
![]() |
Limits | Property that represents limits for this Layout object. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
TabOrder | Property that represents the tab order for this Layout object. |
![]() |
TabSelected | Property that indicates whether this layout tab is selected. |
![]() |
Thumbnail | Property that represents the thumbnail bitmap associated with this layout object. |
![]() |
![]() |
![]() |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
AddToLayoutDictionary | Adds this Layout object to the layout dictionary in the specified database, and associates this Layout object with the specified PaperSpace BlockTableRecord. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
GetViewports | Returns a collection of object identifiers of all the viewports that exist in the paper space layout. The first ID in the list is the overall paper space viewport. If the returned collection is empty, this layout is model space or has never been switched to (activated). |
![]() |
![]() |
![]() |
![]() |
![]() |
Initialize | Initializes a paper space viewport for the layout. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
SwapReferences | This method performs object ID reference translations similar
to those done at the end of deep cloning. References between
objects in the workset have their object identifiers translated to
the swapped object identifiers of the referenced objects. In
contrast to cloning, this translation must occur in both
directions. Accordingly, it is possible to pass two different ID
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
© Bricsys NV. All rights reserved. |