EntityBoundingBoxIntersectWith(Entity,
Intersect, Point3dCollection, Int32,
Int32) Method
|
Note: This API is now obsolete.
Calculates the bounding box for this entity
and then finds the intersections of the passed entity and all the
edges of the bounding box of this entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
[ObsoleteAttribute("Use the overload taking IntPtr instead.")]
public void BoundingBoxIntersectWith(
Entity entityPointer,
Intersect intersectType,
Point3dCollection points,
int thisGraphicSystemMarker,
int otherGraphicSystemMarker
)
<ObsoleteAttribute("Use the overload taking IntPtr instead.")>
Public Sub BoundingBoxIntersectWith (
entityPointer As Entity,
intersectType As Intersect,
points As Point3dCollection,
thisGraphicSystemMarker As Integer,
otherGraphicSystemMarker As Integer
)
public:
[ObsoleteAttribute(L"Use the overload taking IntPtr instead.")]
void BoundingBoxIntersectWith(
Entity^ entityPointer,
Intersect intersectType,
Point3dCollection^ points,
int thisGraphicSystemMarker,
int otherGraphicSystemMarker
)
[<ObsoleteAttribute("Use the overload taking IntPtr instead.")>]
member BoundingBoxIntersectWith :
entityPointer : Entity *
intersectType : Intersect *
points : Point3dCollection *
thisGraphicSystemMarker : int *
otherGraphicSystemMarker : int -> unit
Parameters
- entityPointer Entity
- [in] Entity with which to calculate intersections.
- intersectType Intersect
- [in] Intersection type.
- points Point3dCollection
- [out] Receives an array of intersection points (in WCS
coordinates).
- thisGraphicSystemMarker Int32
- [in] GS marker of the subentity of this entity that is involved
in the intersection operation. May be 0 if not applicable.
- otherGraphicSystemMarker Int32
- [in] GS marker of the subentity of the passed entity that is
involved in the intersection operation. May be 0 if not
applicable.
See Also