EntityBoundingBoxIntersectWith Method

Overload List
  Name Description
Public method BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) Obsolete.
Calculates the bounding box for this entity and then finds the intersections of the passed entity and all the edges of the bounding box of this entity.
Public method BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) Calculates the bounding box for this entity and then finds the intersections of the passed entity and all the edges of the bounding box of this entity.
Public method BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) Obsolete.
Projects the bounding box edges of this entity and the passed entity on the projection plane, calculates the bounding box for this entity, and then finds the intersection points and projects intersections back to the bounding box edge of this entity.
Public method BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) Projects the bounding box edges of this entity and the passed entity on the projection plane, calculates the bounding box for this entity, and then finds the intersection points and projects intersections back to the bounding box edge of this entity.
Top
See Also